Samstag, 26. Dezember 2015

Map tools

There was the wish to simplify some workflows in Map. Here are a few commands we have added:

WIN_FDO_CONVERT_LINES - converts FDO line features to ACAD polylines (layers and color is hard coded, only geometry is converted, not the display style) 
WIN_INTERSECT_LINES - draws point at intersection between two lines (CAD or FDO lines)
WIN_INTERSECT_LINEPOINT - draws point at intersection between existing line (CAD or FDO) and line defined by two points

WIN_FDOLAYER_ISOLATE - isolates the Map layer for selected features
WIN_FDOLAYER_TURNOFF - turns Map layer off for selected features
WIN_FDOLAYER_RESTORE - restores the original visibility settings for Map layers
WIN_FDOLAYERGROUP_VISIBILITY - lets you turn on/off visibility of Map layer groups

For easy use we have put all commands in toolbar:




Maybe there are useful for someone else. 

Instructions:

a) download
b) extract ZIP file
c) unblock the two dll files (otherwise they won't be loaded in Map)
d) copy the two "bundle" folders (WIN_FDO_DynFeatures.bundle, WIN_FDO_Layertools.bundle) to one of Map's default plugin folders (C:\Users\<<user>>\AppData\Roaming\Autodesk\ApplicationPlugins
 or C:\ProgramData\Autodesk\ApplicationPlugins)
e) start Map - dlls will be loaded automatically

Language: german, english.
WIN_FDO_DynFeatures - will not run with Civil
WIN_FDO_Layertools - should run with Map and Civil

Both dlls are more or less tested with Map 2013 but newer version should work as well.

I don't have the time to finish the tools. They do their work in our environment. If you find bugs let me know.

Download


DWG-Export - Missing/wrong z-value

With Map 2013 height information (attribute data in Industry Model) of point features will not be exported as z-value for AutoCAD points/blocks. 
In newer versions of Map the attribute value will be exported but apparently there is a bug so that the AutoCAD points/blocks might get a wrong z-value.

Here is a little tool which assigns the z-value to blocks after exporting the drawing. DWG export needs to include XDATA:
- export the drawing (command: maptoacad) and include XDATA
- configure the XML file according to your needs
- open the exported drawing and run the tool.

Configuration file explanation:
<Block>
        <Infotext>AV - 17.7.2014</Infotext>                    
        <Layername>AV_Höhenfixpunkte</Layername>
        <SpaltennameHoehe>HOEHE</SpaltennameHoehe>                  
        <SpaltennameNummer>PUNKTNUMMER</SpaltennameNummer>
</Block>

<Infotext> - just some information, not processed
<Layername> - AutoCAD layername where to find the blocks
<SpaltennameHoehe> - name of the attribute containing the z-value (your feature class or view needs to have the z-value as attribute in order to get it exported as XDATA)
<SpaltennameNummer> - name of the attribute containg a point number (appears in report)

attribute names in FDO feature source - data needs to be exported as XDATA
This is a stripped down version of a tool containing further dwg export post processing features. Sample drawing is included. Tested with Map 2013, should run with newer versions as well. In german language only.

a) download
b) extract ZIP and unblock DLL (otherwise it won't load in Map)
c) open sample drawing
d) command: netload to load DLL file
e) command: WIN_DWGEXPORTPOSTPROC to run tool
f) load attached sample XML configuration file

Download


Mittwoch, 16. Dezember 2015

MapGuide - Server Admin

MapGuide / AIMS mapagent web site contains a section called "Server Admin". If you try to execute one of the commands you will probably get an error message:

MapGuide Server Admin Service Tests
Problem:\nCannot establish connection to the Infrastructure Map Server.\n\nPossible Causes:\n-Your session has been idle for too long;\n-Infrastructure Map Server is no longer responding;\n-Internet connection problems.\n\nSolution:\nRestart your application / session, restart the Infrastructure Map Server service, or contact with the server administrator.Problem:\nCannot establish connection to the Infrastructure Map Server.\n\nPossible Causes:\n-Your session has been idle for too long;\n-Infrastructure Map Server is no longer responding;\n-Internet connection problems.\n\nSolution:\nRestart your application / session, restart the Infrastructure Map Server service, or contact with the server administrator.


If so then change "localhost" to "127.0.0.1" in file "serveradminhelper". The file can be found in the mapviewer sub folder. Depending on your installation your viewer is either .net, Java or PHP based. For a .net based view the path is:

\www\mapviewernet\

The line in question is (für ASPX):

 serverAdmin.Open("localhost", cred);
and needs to be changed to
 serverAdmin.Open("127.0.0.1", cred);


AIMS 2013.

Mittwoch, 9. Dezember 2015

Migration project finished

For quite some time we were busy migrating TB2 to AutoCAD Map 2013. The poject is now finished, all TB2 clients have been removed, MapGuide 6.5 has been switched off for good. With that the last remaining XP workstations and W2003 servers have been retired as well.
So, what comes next? Upgrade to 2016...

FlexLM - FlexNet Licensing error:-1,359.

I installed FlexLM on W2008R2 and set up our licenses.
When my colleague performed a server status check he received the following error message:

--------
Status
--------
Flexible License Manager status on Wed 12/9/2015 14:13

[Detecting lmgrd processes...]
Error getting status: Cannot find license file.
The license files (or license server system network addresses) attempted are 
listed below.  Use LM_LICENSE_FILE to use a different license file,
or contact your software provider for a license file.
Filename:      C:\flexlm\license.dat
License path:  C:\flexlm\license.dat;
FlexNet Licensing error:-1,359.  System Error: 2 "No such file or directory"
For further information, refer to the FlexNet Licensing documentation,
available at "www.flexerasoftware.com".

When I did the same I just got the server status report as expected.

It turned out that my colleague's registry profile contained a key under

HKEY_CURRENT_USER\Software\FLEXlm License Manager

which pointed to "C:\flexlm\license.dat".

I did not have that key in HKEY_CURRENT_USER.

Deleting the  key in HKEY_CURRENT_USER solved the issue.

FlexLM - Version v11.12.1.4